yuzu Git (2018/10/18) is complied. yuzu is a work-in-progress Nintendo Switch emulator. yuzu is an open-source project, licensed under the GPLv2 (or any later version). yuzu has been designed with portability in mind, with builds available for Windows, Linux, and macOS. The project was started in spring of 2017 by bunnei, one of the original authors of the popular Citra 3DS emulator, to experiment with and research the Nintendo Switch. Due to the similarities between Switch and 3DS, yuzu was developed as a fork of Citra. This means that it uses the same project architecture, and both emulators benefit from shared improvements. During the early months of development, work was done in private, and progress was slow. However, as Switch reverse-engineering and homebrew development became popular, work on yuzu began to take off as well.
yuzu Git Changelog:
* Merge pull request #1444 from ogniK5377/better-hid
* Using dual joycons as the default controller
* Dynamically decide handheld variant based on supported npad id priority
* Added BeginPermitVibrationSession and EndPermitVibrationSession
* Added GetLedPattern and HandheldVariant
* Kirby expects handheld controllers to be at position 8
* Added the ability to “disconnect” individual npads
* Removed unneeded forward declarations
* Addressed changes for better hid
* “Better Hid” rework part 1
* Merge pull request #1489 from FernandoS27/fix-tlds
* Fix TLDS
* Merge pull request #1497 from bunnei/flush-framebuffers
* gl_rasterizer_cache: Remove unnecessary block_depth=1 on Flush.
* gl_rasterizer_cache: Remove unnecessary temporary buffer with unswizzle.
* gl_rasterizer_cache: Use AccurateCopySurface for use_accurate_gpu_emulation.
* config: Rename use_accurate_framebuffers -> use_accurate_gpu_emulation.
* rasterizer_cache: Refactor to support in-order flushing.
* gl_rasterizer_cache: Refactor to only call GetRegionEnd on surface creation.
* gl_rasterizer_cache: Only flush when use_accurate_framebuffers is enabled.
* gl_rasterizer_cache: Separate guest and host surface size managment.
* gl_rasterizer_cache: Rename GetGLBytesPerPixel to GetBytesPerPixel.
* gl_rasterizer_cache: Remove unused FlushSurface method.
* gl_rasterizer: Implement flushing.
* gl_rasterizer_cache: Remove usage of Memory::Read/Write functions.
* gl_rasterizer_cache: Clamp cached surface size to mapped GPU region size.
* memory_manager: Add a method for querying the end of a mapped GPU region.
* rasterizer_cache: Reintroduce method for flushing.
* gl_rasterizer_cache: Reintroduce code for handling swizzle and flush to guest RAM.
* Merge pull request #1498 from lioncash/aslr
* svc: Clarify enum values for AddressSpaceBaseAddr and AddressSpaceSize in svcGetInfo()
* Merge pull request #1496 from FernandoS27/tex-array
* Implement Arrays on Tex Instruction
* Merge pull request #1509 from DarkLordZach/device-save-data
* savedata_factory: Add TemporaryStorage SaveDataSpaceId
* savedata_factory: Add support for DeviceSaveData